全国服务热线:4008-888-888

公司新闻

怎么创建微信小程序_使用命令行东西npm新创建一

使用命令行工具npm新创建一个vue项目的方法       Vue.js 提供一个官方命令行工具,可用于快速搭建大型单页应用。下面小编给大家分享使用命令行工具npm新创建一个vue项目的方法,需要的朋友参考下吧

Vue.js 提供一个官方命令行工具,可用于快速搭建大型单页应用。该工具提供开箱即用的构建工具配置,带来现代化的前端开发流程。

只需几分钟即可创建并启动一个带热重载、保存时静态检查以及可用于生产环境的构建配置的项目:

# 全局安装 vue-cli
$ npm install --global vue-cli
# 创建一个基于 webpack 模板的新项目
$ vue init webpack my-project
$ vue init webpack test //输入命令
 Project name (test) test
 Project name test
 Project description (A Vue.js project) 测试项目
 Project description 测试项目
 Author lxx1024
 Author lxx1024
 Vue build standalone
 Install vue-router (Y/n) Y //安装路由
 Install vue-router Yes
 Use ESLint to lint your code (Y/n) n //Eslint验证,很严谨,所以选择n
 Use ESLint to lint your code No
 Setup unit tests with Karma + Mocha (Y/n) Y
 Setup unit tests with Karma + Mocha Yes
 Setup e2e tests with Nightwatch (Y/n) Y
 Setup e2e tests with Nightwatch Yes
 vue-cli · Generated "test".
 To get started:
 cd test
 npm install
 npm run dev
 Documentation can be found at webpack
# 安装依赖,走你
$ cd my-project
$ npm install
$ npm run dev //运行项目

npm install phantomjs-.15 install C:\Users\81487\Desktop\test\node_modules\phantomjs-prebuilt node install.js PhantomJS not found on PATH Downloading Medium/phantomjs/releases/download/v2.1.1/phantomjs-2.1.1-windows.zip Saving to C:\Users\81487\AppData\Local\Temp\phantomjs\phantomjs-2.1.1-windows.zip Receiving... Error making request. Error: connect ETIMEDOUT 54.231.81.168:443 at Object.exports._errnoException (util.js:1020:11) at exports._exceptionWithHostPort (util.js:1043:20) at TCPConnectWrap.afterConnect [plete] (net.js:1090:14) Please report this full log at Medium/phantomjs .0 C:\Users\81487\Desktop\test +-- .5 | +-- .1 | | `-- electron-to-.26 | +-- caniuse-. | +-- normalize-.2 | +-- .2 | +-- .13 | `-- postcss-value-.0 +-- babel-.0 | +-- babel-code-.0 | | +-- .3 | | | +-- ansi-.1 | | | `-- supports-.0 | | +-- .2 | | `-- js-.2 | +-- babel-.0 | | +-- detect-.0 | | | `-- .1 | | | `-- is-.2 | | | `-- number-is-.1 | | +-- .0 | | +-- source-.7 | | `-- trim-.1 | +-- babel-.1 | +-- babel-.0 | +-- babel-.0 | | `-- regenerator-.0 | +-- babel-.0 | +-- babel-.0 | | `-- .0 | +-- babel-.0 | | `-- to-fast-.3 | +-- .0 | +-- convert-source-.0 | +-- .9 | | `-- .0 | +-- .1 | +-- .4 | +-- .4 | | `-- brace-.8 | | +-- balanced-.0 | | `-- concat-.1 | +-- path-is-.1 | +-- .7 | +-- .0 | `-- source-.7 +-- babel-.2 | +-- find-cache-.0 | | +-- .1 | | +-- make-.0 | | | `-- .0 | | `-- pkg-.0 | +-- loader-.0 | | +-- big..0 | | `-- emojis-.0 | `-- .1 | `-- .8 +-- babel-plugin-.5 | +-- find-.0 | | `-- locate-.0 | | +-- p-.0 | | | `-- p-.0 | | `-- path-.0 | +-- istanbul-lib-.0 | | `-- istanbul-lib-.1 | `-- test-.1 | +-- .1 | +-- read-pkg-.1 | | +-- find-.2 | | | +-- path-.0 | | | `-- pinkie-.1 | | | `-- .4 | | `-- read-.0 | | +-- load-json-.0 | | | `-- strip-.0 | | | `-- is-.1 | | `-- path-.0 | `-- require-main-.1 +-- babel-plugin-transform-.0 +-- babel-preset-.0 | +-- babel-plugin-check-es2015-.0 | +-- babel-plugin-syntax-trailing-function-.0 | +-- babel-plugin-transform-async-to-.1 | | +-- babel-helper-remap-async-to-.1 | | `-- babel-plugin-syntax-async-.0 | +-- babel-plugin-transform-es2015-arrow-.0 | +-- babel-plugin-transform-es2015-block-scoped-.0 | +-- babel-plugin-transform-es2015-block-.0 | +-- babel-plugin-transform-es2015-.1 | | +-- babel-helper-define-.0 | | +-- babel-helper-function-.1 | | +-- babel-helper-optimise-call-.1 | | `-- babel-helper-replace-.1 | +-- babel-plugin-puted-.1 | +-- babel-plugin-transform-es2015-.0 | +-- babel-plugin-transform-es2015-duplicate-.1 | +-- babel-plugin-transform-es2015-for-.0 | +-- babel-plugin-transform-es2015-function-.1 | +-- babel-plugin-transform-es2015-.0 | +-- babel-plugin-transform-es2015-modules-.1 | +-- babel-plugin-transform-es2015-modules-.0 | | `-- babel-plugin-transform-strict-.1 | +-- babel-plugin-transform-es2015-modules-.1 | | `-- babel-helper-hoist-.1 | +-- babel-plugin-transform-es2015-modules-.1 | +-- babel-plugin-transform-es2015-object-.1 | +-- babel-plugin-transform-es2015-.1 | | +-- babel-helper-call-.1 | | `-- babel-helper-get-function-.1 | +-- babel-plugin-transform-es2015-shorthand-.1 | +-- babel-plugin-transform-es2015-.0 | +-- babel-plugin-transform-es2015-sticky-.1 | | `-- babel-helper-.0 | +-- babel-plugin-transform-es2015-template-.0 | +-- babel-plugin-transform-es2015-typeof-.0 | +-- babel-plugin-transform-es2015-unicode-.1 | | `-- regexpu-.0 | | +-- .3 | | +-- .0 | | `-- .5 | | `-- .0 | +-- babel-plugin-transform-exponentiation-.1 | | +-- babel-helper-builder-binary-assignment-operator-.1 | | | `-- babel-helper-explode-assignable-.1 | | `-- babel-plugin-syntax-exponentiation-.0 | +-- babel-plugin-transform-.0 | | `-- regenerator-.1 | `-- .2 | `-- loose-.1 +-- babel-preset-stage-.1 | +-- babel-plugin-syntax-dynamic-.0 | +-- babel-plugin-transform-class-.1 | | `-- babel-plugin-syntax-class-.0 | +-- babel-plugin-transform-.1 | | +-- babel-helper-explode-.1 | | | `-- babel-helper-bindify-.1 | | `-- babel-plugin-syntax-.0 | `-- babel-preset-stage-.1 | +-- babel-plugin-transform-async-generator-.1 | | `-- babel-plugin-syntax-async-.0 | `-- babel-plugin-transform-object-rest-.0 | `-- babel-plugin-syntax-object-rest-.0 +-- babel-.0 | +-- core-.1 | +-- home-or-.0 | | +-- os-.2 | | `-- os-.2 | `-- source-map-.18 | `-- source-.7 +-- .2 | +-- assertion-.2 | +-- check-.2 | +-- deep-.1 | +-- get-func-.0 | +-- .0 | `-- type-.3 +-- .0 | +-- ansi-.0 | | `-- color-.0 | | `-- color-.3 | +-- escape-string-.5 | `-- supports-.0 | `-- has-.0 +-- .1 | +-- extract-.5 | | +-- concat-.0 | | | `-- .6 | | +-- .0 | | | `-- .1 | | +-- .0 | | `-- .1 | | `-- fd-.1 | | `-- .0 | +-- .0 | `-- .0 | +-- aws-.0 | +-- .0 | +-- .0 | +-- combined-.5 | | `-- delayed-.0 | +-- .1 | +-- forever-.1 | +-- form-.1 | | `-- .0 | +-- har-.3 | | `-- har-.0 | +-- .2 | | +-- .1 | | +-- .2 | | | `-- .0 | | +-- .0 | | `-- .2 | +-- http-.0 | | +-- assert-.0 | | +-- .1 | | | +-- .0 | | | +-- json-.3 | | | `-- .0 | | `-- .1 | | +-- .3 | | +-- bcrypt-.1 | | +-- .1 | | +-- ecc-.1 | | +-- .7 | | +-- .1 | | `-- .5 | +-- is-.0 | +-- .2 | +-- json-stringify-.1 | +-- mime-.17 | | `-- mime-.0 | +-- oauth-.2 | +-- performance-.0 | +-- .5 | +-- tough-.3 | +-- tunnel-.0 | `-- .0 +-- connect-history-api-.0 +-- copy-webpack-.1 | +-- .1 | +-- fs-.2 | | +-- .0 | | `-- .1 | +-- .2 | | +-- fs..0 | | +-- .6 | | | `-- .2 | | +-- .3 | | `-- .0 | +-- is-.0 | | `-- is-.1 | +-- loader-.17 | `-- node-.17 +-- cross-.5 | `-- is-.1 +-- cross-.0 | +-- lru-.1 | | +-- .2 | | `-- .2 | +-- shebang-.0 | | `-- shebang-.0 | `-- .0 | `-- .0 +-- css-.7 | +-- css-selector-.0 | | +-- .0 | | +-- .1 | | `-- regexpu-.0 | +-- .0 | | +-- .7 | | | +-- .7 | | | `-- caniuse-. | | +-- .0 | | +-- .0 | | +-- .1 | | | `-- function-.1 | | +-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-.1 | | | +-- .18 | | | | +-- .3 | | | | | +-- ansi-.1 | | | | | `-- supports-.0 | | | | +-- source-.7 | | | | `-- supports-.3 | | | | `-- has-.0 | | | +-- postcss-message-.0 | | | `-- reduce-css-.0 | | | +-- balanced-.2 | | | +-- math-expression-.17 | | | `-- reduce-function-.2 | | | `-- balanced-.2 | | +-- postcss-.2 | | | +-- .2 | | | | +-- .4 | | | | | +-- .2 | | | | | `-- color-.0 | | | | `-- css-color-.4 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-convert-.1 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-discard-.4 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-discard-.0 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-discard-.0 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-discard-.1 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-discard-.3 | | | +-- .18 | | | | +-- .3 | | | | | +-- ansi-.1 | | | | | `-- supports-.0 | | | | +-- source-.7 | | | | `-- supports-.3 | | | | `-- has-.0 | | | `-- .0 | | +-- postcss-filter-.2 | | | +-- .18 | | | | +-- .3 | | | | | +-- ansi-.1 | | | | | `-- supports-.0 | | | | +-- source-.7 | | | | `-- supports-.3 | | | | `-- has-.0 | | | `-- .1 | | | `-- .8 | | +-- postcss-merge-.7 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-merge-.2 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-merge-.2 | | | +-- .7 | | | +-- caniuse-.1 | | | | +-- .7 | | | | +-- lodash..2 | | | | `-- lodash..0 | | | +-- .18 | | | | +-- .3 | | | | | +-- ansi-.1 | | | | | `-- supports-.0 | | | | +-- source-.7 | | | | `-- supports-.3 | | | | `-- has-.0 | | | `-- .1 | | +-- postcss-minify-font-.5 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-minify-.5 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-minify-.2 | | | +-- alphanum-.2 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-minify-.1 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-normalize-.1 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-normalize-.8 | | | +-- is-absolute-.0 | | | +-- normalize-.1 | | | | +-- prepend-.4 | | | | +-- query-.4 | | | | | `-- strict-uri-.0 | | | | `-- sort-.2 | | | | `-- is-plain-.0 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-ordered-.3 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-reduce-.0 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-reduce-.1 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-reduce-.4 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | +-- postcss-.6 | | | +-- is-.0 | | | | `-- ment-.1 | | | +-- .18 | | | | +-- .3 | | | | | +-- ansi-.1 | | | | | `-- supports-.0 | | | | +-- source-.7 | | | | `-- supports-.3 | | | | `-- has-.0 | | | `-- .2 | | | +-- .4 | | | | `-- .0 | | | +-- .2 | | | | +-- .3 | | | | | `-- .3 | | | | | +-- ansi-.1 | | | | | `-- supports-.0 | | | | `-- source-.7 | | | +-- .4 | | | `-- whet..9 | | +-- postcss-unique-.2 | | | `-- .18 | | | +-- .3 | | | | +-- ansi-.1 | | | | `-- supports-.0 | | | +-- source-.7 | | | `-- supports-.3 | | | `-- has-.0 | | `-- postcss-.0 | | `-- .18 | | +-- .3 | | | +-- ansi-.1 | | | `-- supports-.0 | | +-- source-.7 | | `-- supports-.3 | | `-- has-.0 | +-- icss-.0 | +-- lodash..0 | +-- object-.1 | +-- .18 | | +-- .3 | | | +-- ansi-.1 | | | `-- supports-.0 | | +-- js-.2 | | +-- source-.7 | | `-- supports-.3 | | `-- has-.0 | +-- postcss-modules-extract-.0 | +-- postcss-modules-local-by-.0 | +-- postcss-modules-.0 | +-- postcss-modules-.0 | | `-- icss-replace-.0 | `-- source-list-.0 +-- eventsource-.6 +-- .2 | +-- .4 | | `-- .1 | +-- array-.1 | +-- body-.2 | | +-- .0 | | +-- http-.2 | | | `-- .3 | | +-- iconv-.19 | | `-- raw-.2 | +-- content-.2 | +-- content-.4 | +-- .1 | +-- cookie-.6 | +-- .1 | +-- .1 | +-- escape-.3 | +-- .1 | +-- .0 | | `-- .0 | +-- .2 | +-- merge-.1 | +-- .2 | +-- on-.0 | | `-- ee-.1 | +-- .2 | +-- path-to-.7 | +-- proxy-.2 | | +-- .2 | | `-- ipaddr..2 | +-- .1 | +-- range-.0 | +-- safe-.1 | +-- .1 | | `-- .4 | +-- serve-.1 | +-- .0 | +-- .1 | +-- type-.15 | | `-- media-.0 | +-- utils-.1 | `-- .2 +-- extract-text-webpack-.1 | +-- .0 | +-- schema-.0 | `-- webpack-.1 | `-- source-.7 +-- file-.5 +-- friendly-errors-webpack-.1 | +-- .3 | | +-- ansi-.1 | | +-- has-.0 | | `-- supports-.0 | +-- error-stack-.1 | | `-- .4 | `-- string-.1 +-- html-webpack-.1 | +-- html-.5 | | +-- camel-.0 | | | +-- no-.2 | | | | `-- lower-.4 | | | `-- upper-.3 | | +-- clean-.9 | | | `-- source-.7 | | +-- .0 | | | `-- xml-char-.0 | | +-- param-.1 | | +-- .7 | | `-- uglify-.3 | | `-- source-.7 | +-- loader-.17 | +-- pretty-.1 | | +-- .1 | | | +-- css-.0 | | | | +-- .0 | | | | +-- css-.0 | | | | +-- .1 | | | | | `-- dom-.0 | | | | | +-- .3 | | | | | `-- .1 | | | | `-- nth-.1 | | | +-- dom-.4 | | | | `-- .3 | | | +-- .0 | | | | +-- .0 | | | | +-- .0 | | | | +-- .6 | | | | `-- readable-.34 | | | | +-- .1 | | | | `-- .31 | | | `-- .3 | | `-- .0 | `-- .6 +-- http-proxy-.4 | +-- http-.2 | | +-- .0 | | `-- requires-.0 | +-- is-.0 | | `-- is-.1 | `-- .11 | +-- arr-.0 | | `-- arr-.0 | +-- array-.1 | +-- .5 | | +-- expand-.2 | | | `-- fill-.3 | | | +-- is-.0 | | | +-- .0 | | | +-- .7 | | | | +-- is-.0 | | | | | `-- kind-.2 | | | | `-- kind-.0 | | | `-- repeat-.1 | | +-- .0 | | `-- repeat-.2 | +-- expand-.5 | | `-- is-posix-.1 | +-- .2 | +-- filename-.1 | +-- is-.0 | +-- is-.1 | +-- kind-.2 | | `-- is-.5 | +-- normalize-.1 | | `-- remove-trailing-.0 | +-- object..1 | | +-- for-.5 | | | `-- for-.2 | | `-- is-.1 | +-- parse-.4 | | +-- glob-.0 | | `-- is-.3 | `-- regex-.4 | `-- is-equal-.3 | `-- is-.0 +-- inject-.1 +-- .1 | +-- .0 | | +-- .2 | | +-- async-.1 | | +-- glob-.0 | | +-- is-binary-.1 | | | `-- binary-.0 | | `-- .0 | | `-- set-immediate-.1 | +-- .2 | +-- combine-.1 | +-- .5 | | `-- .6 | +-- .1 | +-- dom-.1 | | +-- custom-.1 | | +-- .0 | | `-- void-.1 | +-- expand-.2 | | +-- array-.3 | | `-- .5 | | `-- expand-.1 | | +-- is-.1 | | `-- repeat-.2 | +-- graceful-.11 | +-- .2 | +-- .1 | +-- .38 | | +-- readable-.34 | | | +-- core-util-.2 | | | +-- .1 | | | `-- .31 | | `-- .6 | +-- .1 | +-- .1 | | `-- .3 | +-- .5 | +-- socket..3 | | +-- .3 | | | `-- .2 | | +-- engine..3 | | | +-- .3 | | | +-- .0 | | | +-- .3 | | | | `-- .2 | | | +-- engine.io-.2 | | | | +-- .2 | | | | +-- arraybuffer..6 | | | | +-- base64-.5 | | | | +-- .4 | | | | `-- wtf-.0 | | | `-- .2 | | | +-- .6 | | | `-- .2 | | +-- has-.7 | | | `-- .1 | | +-- object-.0 | | +-- socket.io-.0 | | | `-- .3 | | | `-- .2 | | +-- socket.io-.3 | | | +-- .2 | | | +-- component-.0 | | | +-- component-.1 | | | +-- .3 | | | | `-- .2 | | | +-- engine.io-.3 | | | | +-- component-.1 | | | | +-- component-.3 | | | | +-- .3 | | | | | `-- .2 | | | | +-- has-.0 | | | | +-- .3 | | | | +-- .5 | | | | +-- xmlhttprequest-.3 | | | | `-- .2 | | | +-- .1 | | | +-- object-.3 | | | +-- .5 | | | | `-- better-.2 | | | | `-- .0 | | | `-- to-.4 | | `-- socket.io-.1 | | +-- component-.2 | | +-- .0 | | | `-- .1 | | `-- .1 | +-- source-.7 | +-- .31 | `-- .1 | `-- lru-.4 +-- karma-.1 | +-- .12 | | +-- get-.1 | | `-- .0 | | +-- camelcase-.0 | | | `-- .1 | | +-- loud-.0 | | | `-- currently-.1 | | | `-- array-find-.2 | | +-- map-.1 | | +-- .0 | | +-- normalize-package-.0 | | | +-- hosted-git-.0 | | | +-- is-builtin-.0 | | | | `-- builtin-.1 | | | `-- validate-npm-package-.1 | | | +-- spdx-.2 | | | | `-- spdx-license-.2 | | | `-- spdx-expression-.4 | | +-- .0 | | | +-- indent-.0 | | | `-- strip-.1 | | `-- trim-.0 | +-- .5 | | +-- .9 | | +-- .2 | | +-- .1 | | | +-- .3 | | | +-- .2 | | | | +-- deep-.3 | | | | +-- fast-.6 | | | | +-- .0 | | | | +-- prelude-.2 | | | | +-- type-.2 | | | | `-- .0 | | | `-- source-.0 | | +-- .3 | | +-- .15 | | +-- .10 | | | +-- .2 | | | +-- source-.4 | | | `-- uglify-.29 | | | `-- source-.7 | | +-- js-.0 | | | `-- .9 | | | `-- sprintf-.3 | | +-- .6 | | +-- .7 | | +-- supports-.3 | | | `-- has-.0 | | `-- .0 | +-- .1 | `-- source-.7 +-- karma-.0 | `-- .0 +-- karma-phantomjs-.0 +-- karma-sinon-.2 | `-- .0 +-- karma-sourcemap-.7 +-- karma-spec-.31 +-- karma-.5 | +-- .2 | +-- loader-.17 | +-- .1 | `-- source-.43 | `-- .1 +-- .3 | +-- browser-.0 | +-- .0 | | `-- graceful-.1 | +-- .8 | +-- .0 | +-- .1 | +-- .2 | +-- .1 | +-- .2 | +-- lodash..1 | | +-- lodash..0 | | | +-- lodash..1 | | | `-- lodash..2 | | | +-- lodash..1 | | | `-- lodash..0 | | +-- lodash..3 | | `-- lodash..9 | `-- supports-.2 | `-- has-.0 +-- .16 | +-- chai-.1 | | +-- assertion-.0 | | `-- deep-.3 | | `-- type-.1 | +-- .3 | +-- lodash..3 | | +-- lodash..0 | | | +-- lodash..0 | | | +-- lodash..0 | | | +-- lodash..3 | | | `-- lodash..4 | | `-- lodash..1 | +-- lodash..2 | | +-- lodash..7 | | +-- lodash..3 | | +-- lodash..6 | | +-- lodash..0 | | +-- lodash..0 | | `-- lodash..5 | +-- .3 | +-- .0 | +-- mocha-.2 | | +-- .0 | | +-- .0 | | | `-- .1 | | +-- .0 | | +-- .5 | | `-- supports-.2 | | `-- has-.0 | +-- proxy-.0 | | +-- agent-.1 | | | `-- .3 | | +-- http-proxy-.0 | | +-- htt凡科抠图-proxy-.0 | | +-- lru-.5 | | +-- pac-proxy-.0 | | | +-- get-.1 | | | | +-- data-uri-to-.0 | | | | +-- file-uri-to-.0 | | | | `-- .10 | | | | +-- readable-.14 | | | | | +-- .1 | | | | | `-- .31 | | | | `-- .0 | | | `-- pac-.0 | | | +-- .6 | | | +-- .4 | | | | +-- ast-.14 | | | | `-- .3 | | | +-- .1 | | | +-- .6 | | | `-- .2 | | `-- socks-proxy-.1 | | `-- .10 | | +-- .5 | | `-- smart-.15 | `-- .1 +-- .0 | `-- is-.0 +-- optimize-css-assets-webpack-.0 | `-- last-call-webpack-.2 +-- .0 | +-- .3 | | +-- ansi-.1 | | `-- supports-.0 | +-- cli-.0 | | `-- restore-.0 | | +-- .1 | | | `-- mimic-.0 | | `-- signal-.2 | +-- cli-.0 | `-- log-.2 | `-- .3 | +-- ansi-.1 | `-- supports-.0 +-- .13 | `-- .2 +-- .2 +-- selenium-.0 +-- .1 +-- .8 | +-- .4 | `-- .2 +-- UNMET PEER DEPENDENCY .1 | +-- .0 | +-- lodash..2 | +-- .3 | +-- native-promise-.1 | +-- .1 | | +-- just-.22 | | `-- path-to-.0 | | `-- .1 | +-- path-to-.0 | | `-- .1 | +-- .0 | `-- text-.4 +-- sinon-.0 +-- url-.9 | `-- .6 +-- .4 +-- vue-.0 | +-- .5 | +-- hash-.2 | +-- postcss-load-.0 | | +-- .2 | | | +-- is-.1 | | | +-- .0 | | | +-- parse-.0 | | | | `-- error-.1 | | | | `-- is-.1 | | | `-- require-from-.1 | | +-- postcss-load-.0 | | `-- postcss-load-.0 | +-- postcss-selector-.3 | | +-- .2 | | +-- indexes-.1 | | `-- .1 | +-- .4 | +-- .0 | | `-- path-.5 | +-- source-.1 | +-- vue-hot-reload-.0 | `-- vue-template-es2015-.0 +-- vue-.0 +-- vue-style-.3 +-- vue-template-.4 | `-- de-.2 +-- .1 | +-- .2 | +-- acorn-dynamic-.2 | | `-- .13 | +-- .3 | | +-- .0 | | +-- fast-deep-.0 | | +-- json-schema-.1 | | `-- json-stable-.1 | | `-- .0 | +-- ajv-.0 | +-- enhanced-.1 | +-- .0 | | +-- es6-.5 | | | +-- .0 | | | +-- es5-.31 | | | +-- es6-.1 | | | +-- es6-.5 | | | +-- es6-.1 | | | `-- event-.5 | | +-- es6-weak-.2 | | +-- .0 | | | `-- .0 | | `-- .0 | +-- json-.7 | +-- loader-.0 | +-- memory-.1 | | +-- .4 | | | `-- .0 | | `-- readable-.3 | | +-- .0 | | +-- process-nextick-.7 | | +-- .3 | | `-- util-.2 | +-- node-libs-.0 | | +-- .1 | | +-- browserify-.4 | | | `-- .9 | | +-- .1 | | | +-- base64-.1 | | | `-- .8 | | +-- console-.0 | | | `-- date-.4 | | +-- constants-.0 | | +-- crypto-.1 | | | +-- browserify-.0 | | | | +-- browserify-.8 | | | | | `-- buffer-.3 | | | | +-- browserify-.0 | | | | | `-- des..0 | | | | `-- .3 | | | | `-- md5..4 | | | | `-- hash-.4 | | | +-- browserify-.4 | | | | +-- bn..8 | | | | +-- browserify-.1 | | | | +-- .0 | | | | | +-- .0 | | | | | +-- hash..3 | | | | | +-- hmac-.1 | | | | | +-- minimalistic-.0 | | | | | `-- minimalistic-crypto-.1 | | | | `-- parse-.0 | | | | `-- asn1..1 | | | +-- create-.0 | | | +-- create-.3 | | | | +-- cipher-.4 | | | | +-- .1 | | | | | `-- hash-.2 | | | | `-- sha..9 | | | +-- create-.6 | | | +-- diffie-.2 | | | | `-- miller-.1 | | | +-- .14 | | | +-- public-.0 | | | `-- .5 | | +-- domain-.7 | | +-- .1 | | +-- htt凡科抠图-.1 | | +-- os-.1 | | +-- path-.0 | | +-- .10 | | +-- .1 | | +-- querystring-.1 | | +-- stream-.1 | | +-- stream-.2 | | | +-- builtin-status-.0 | | | +-- to-.1 | | | `-- .1 | | +-- .31 | | +-- timers-.4 | | | `-- .5 | | +-- tty-.0 | | +-- .0 | | | `-- .2 | | +-- .3 | | | `-- .1 | | `-- vm-.4 | +-- source-.7 | +-- .8 | +-- uglifyjs-webpack-.6 | | +-- source-.7 | | `-- uglify-.29 | | +-- uglify-to-.2 | | `-- .0 | | +-- .1 | | +-- .0 | | | +-- center-.3 | | | | +-- align-.4 | | | | | `-- .1 | | | | `-- lazy-.4 | | | +-- right-.3 | | | `-- .2 | | `-- window-.0 | +-- .0 | `-- .2 | +-- .0 | +-- .0 | | +-- string-.2 | | | +-- code-point-.0 | | | `-- is-fullwidth-code-.0 | | `-- wrap-.0 | | `-- string-.2 | +-- get-caller-.2 | +-- os-.0 | | +-- .0 | | | +-- get-.0 | | | +-- is-.0 | | | +-- npm-run-.2 | | | | `-- path-.1 | | | +-- p-.0 | | | `-- strip-.0 | | +-- .0 | | | `-- invert-.0 | | `-- .0 | +-- read-pkg-.0 | | `-- read-.0 | | +-- load-json-.0 | | | `-- strip-.0 | | `-- path-.0 | +-- require-.1 | +-- set-.0 | +-- string-.1 | | +-- is-fullwidth-code-.0 | | `-- strip-.0 | | `-- ansi-.0 | +-- which-.0 | +-- .1 | `-- yargs-.0 | `-- .0 +-- webpack-bundle-.0 | +-- .3 | | +-- ansi-.1 | | `-- supports-.0 | +-- .0 | +-- .7 | +-- .10 | +-- gzip-.0 | | `-- .1 | +-- .3 | `-- .1 | +-- safe-.1 | `-- .0 +-- webpack-dev-.0 | `-- time-.0 +-- webpack-hot-.1 | +-- ansi-.7 | +-- html-.1 | +-- .0 | `-- strip-.1 | `-- ansi-.1 `-- webpack-.0 npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\chokidar\node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for .2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN karma-sinon-.2 requires a peer of sinon@^2.1.0 but none was installed. npm ERR! Windows_NT 10.0.10240 npm ERR! argv "E:\\nodejs\\node.exe" "E:\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" npm ERR! node v6.11.4 npm ERR! npm v3.10.10 npm ERR! code ELIFECYCLE npm ERR! phantomjs-.15 install: `node install.js` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the phantomjs-.15 install script 'node install.js'. npm ERR! Make sure you have the latest version of node.js and npm installed. npm ERR! If you do, this is most likely a problem with the phantomjs-prebuilt package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! node install.js npm ERR! You rmation on how to open an issue for this project with: npm ERR! npm bugs phantomjs-prebuilt npm ERR! Or if that isn't available, you can via: npm ERR! npm owner ls phantomjs-prebuilt npm ERR! There is likely additional logging output above. npm ERR! Please include the following file with any support request: npm ERR! C:\Users\81487\Desktop\test\npm-debug.log $ npm run dev node build/dev-server.js Starting dev server... DONE essfully in 15700ms Listening at pre>

总结

以上所述是小编给大家介绍的使用命令行工具npm新创建一个vue项目的方法,希望对大家有所帮助,如果大家有任何疑问请给我留言,小编会及时回复大家的。在此也非常感谢大家对凡科网站的支持!




在线客服

关闭

客户服务热线
4008-888-888


点击这里给我发消息 在线客服

点击这里给我发消息 在线客服